#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ServerConfig="(.*)\b(name=[^\s]+)\b(.*)"|"(.*)\b(name=[^\s]+)?""
Local $sString = "ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=webserver"" & @CRLF & _
"ServerConfig=" ip=10.0.0.0 dns=10.0.0.1"" & @CRLF & _
"ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver"" & @CRLF & _
"ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver type=done"" & @CRLF & _
"ServerConfig="name=dataserver type=done"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")