import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ServerConfig=\"(.*)\\b(name=[^\\s]+)\\b(.*)\"|\"(.*)\\b(name=[^\\s]+)?\"";
final String string = "ServerConfig=\" ip=10.0.0.0 dns=10.0.0.1 name=webserver\"\n"
+ "ServerConfig=\" ip=10.0.0.0 dns=10.0.0.1\"\n"
+ "ServerConfig=\" ip=10.0.0.0 dns=10.0.0.1 name=dataserver\"\n"
+ "ServerConfig=\" ip=10.0.0.0 dns=10.0.0.1 name=dataserver type=done\"\n"
+ "ServerConfig=\"name=dataserver type=done\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}