import Foundation
let pattern = #"ServerConfig="(.*)\b(name=[^\s]+)\b(.*)"|"(.*)\b(name=[^\s]+)?""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=webserver"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver"
ServerConfig=" ip=10.0.0.0 dns=10.0.0.1 name=dataserver type=done"
ServerConfig="name=dataserver type=done"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)