using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ServerConfig=""(.*)\b(name=[^\s]+)\b(.*)""|""(.*)\b(name=[^\s]+)?""";
string input = @"ServerConfig="" ip=10.0.0.0 dns=10.0.0.1 name=webserver""
ServerConfig="" ip=10.0.0.0 dns=10.0.0.1""
ServerConfig="" ip=10.0.0.0 dns=10.0.0.1 name=dataserver""
ServerConfig="" ip=10.0.0.0 dns=10.0.0.1 name=dataserver type=done""
ServerConfig=""name=dataserver type=done""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}