# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{3}(?!\b)/$0 /gm;t' <<< "900123456
90012345
90012"