use strict;
my $str = '900123456
90012345
90012';
my $regex = qr/\d{3}(?!\b)/mp;
my $subst = '$0 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";