const regex = /\d{3}(?!\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{3}(?!\\b)', 'gm')
const str = `900123456
90012345
90012`;
const subst = `$0 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);