import re
regex = re.compile(r"\d{3}(?!\b)", flags=re.MULTILINE)
test_str = ("900123456\n"
"90012345\n"
"90012")
subst = "$0 "
result = regex.sub(subst, test_str)
if result:
print(result)