import Foundation
let pattern = #"\d{3}(?!\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
900123456
90012345
90012
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)