#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d{3}(?!\b)"
Local $sString = "900123456" & @CRLF & _
"90012345" & @CRLF & _
"90012"
Local $sSubst = "$0 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)