$re = '/\d{3}(?!\b)/m';
$str = '900123456
90012345
90012';
$subst = "$0 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;