#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\s*(i\s*sotype control)|(Dilution Buffer)|\s+(anti-)|^(InVivo\w*\s*(?:polyclonal|recombinant)\s*.*(?:sFlts|CTLA|IgG))|(?:\s*)(IgG\s*.*fragments)$|(InVivoPlus mouse CTLA-4 \(CD152\))"
Local $sString = "Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgG)" & @CRLF & _
"Enhanced Chemiluminescent Reagent Kit (Anti-Rabbit IgG)" & @CRLF & _
"Enhanced Chemiluminescent Reagent Kit (Anti-Goat IgG)" & @CRLF & _
"Enhanced Chemiluminescent Reagent Kit (Anti-Rat IgG)" & @CRLF & _
"Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgM)" & @CRLF & _
"Western Blotting Mouse IgG DAB Chromogenic Reagent Kit (Yellow)" & @CRLF & _
"Western Blotting Goat IgG DAB Chromogenic Reagent Kit (Yellow)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")