$re = '/\s*(i\s*sotype control)|(Dilution Buffer)|\s+(anti-)|^(InVivo\w*\s*(?:polyclonal|recombinant)\s*.*(?:sFlts|CTLA|IgG))|(?:\s*)(IgG\s*.*fragments)$|(InVivoPlus mouse CTLA-4 \(CD152\))/mi';
$str = 'Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rabbit IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Goat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgM)
Western Blotting Mouse IgG DAB Chromogenic Reagent Kit (Yellow)
Western Blotting Goat IgG DAB Chromogenic Reagent Kit (Yellow)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);