import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(i\\s*sotype control)|(Dilution Buffer)|\\s+(anti-)|^(InVivo\\w*\\s*(?:polyclonal|recombinant)\\s*.*(?:sFlts|CTLA|IgG))|(?:\\s*)(IgG\\s*.*fragments)$|(InVivoPlus mouse CTLA-4 \\(CD152\\))";
final String string = "Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgG)\n"
+ "Enhanced Chemiluminescent Reagent Kit (Anti-Rabbit IgG)\n"
+ "Enhanced Chemiluminescent Reagent Kit (Anti-Goat IgG)\n"
+ "Enhanced Chemiluminescent Reagent Kit (Anti-Rat IgG)\n"
+ "Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgM)\n"
+ "Western Blotting Mouse IgG DAB Chromogenic Reagent Kit (Yellow)\n"
+ "Western Blotting Goat IgG DAB Chromogenic Reagent Kit (Yellow)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}