import Foundation
let pattern = #"\s*(i\s*sotype control)|(Dilution Buffer)|\s+(anti-)|^(InVivo\w*\s*(?:polyclonal|recombinant)\s*.*(?:sFlts|CTLA|IgG))|(?:\s*)(IgG\s*.*fragments)$|(InVivoPlus mouse CTLA-4 \(CD152\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rabbit IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Goat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgM)
Western Blotting Mouse IgG DAB Chromogenic Reagent Kit (Yellow)
Western Blotting Goat IgG DAB Chromogenic Reagent Kit (Yellow)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)