// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\s*(i\s*sotype control)|(Dilution Buffer)|\s+(anti-)|^(InVivo\w*\s*(?:polyclonal|recombinant)\s*.*(?:sFlts|CTLA|IgG))|(?:\s*)(IgG\s*.*fragments)$|(InVivoPlus mouse CTLA-4 \(CD152\))").unwrap();
let string = "Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rabbit IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Goat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgM)
Western Blotting Mouse IgG DAB Chromogenic Reagent Kit (Yellow)
Western Blotting Goat IgG DAB Chromogenic Reagent Kit (Yellow)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}