use strict;
my $str = 'Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rabbit IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Goat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgM)
Western Blotting Mouse IgG DAB Chromogenic Reagent Kit (Yellow)
Western Blotting Goat IgG DAB Chromogenic Reagent Kit (Yellow)
';
my $regex = qr/\s*(i\s*sotype control)|(Dilution Buffer)|\s+(anti-)|^(InVivo\w*\s*(?:polyclonal|recombinant)\s*.*(?:sFlts|CTLA|IgG))|(?:\s*)(IgG\s*.*fragments)$|(InVivoPlus mouse CTLA-4 \(CD152\))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}