using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(i\s*sotype control)|(Dilution Buffer)|\s+(anti-)|^(InVivo\w*\s*(?:polyclonal|recombinant)\s*.*(?:sFlts|CTLA|IgG))|(?:\s*)(IgG\s*.*fragments)$|(InVivoPlus mouse CTLA-4 \(CD152\))";
string input = @"Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rabbit IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Goat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Rat IgG)
Enhanced Chemiluminescent Reagent Kit (Anti-Mouse IgM)
Western Blotting Mouse IgG DAB Chromogenic Reagent Kit (Yellow)
Western Blotting Goat IgG DAB Chromogenic Reagent Kit (Yellow)
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}