using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w* \w*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})";
string substitution = @"";
string input = @"Hans Wurst_12345678_NOZ1234567_24.04.2018";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}