import re
regex = re.compile(r"^(\w* \w*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})")
test_str = "Hans Wurst_12345678_NOZ1234567_24.04.2018"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)