use strict;
my $str = 'Hans Wurst_12345678_NOZ1234567_24.04.2018';
my $regex = qr/^(\w* \w*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";