re = /^(\w* \w*)_(\d{8})_(NOZ\d{7})_(\d{2}.\d{2}.\d{4})/
str = 'Hans Wurst_12345678_NOZ1234567_24.04.2018'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result