#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:"(?:\\.|[^"\\])*"|'(?:\\.|[^'\\])*')|(\/\/.*$|^\s*\/\/.*$)"
Local $sString = "{" & @CRLF & _
" "example": "This is a // test"," & @CRLF & _
" "anotherExample": "This is another /// test"," & @CRLF & _
" 'ap\//ostr//ophe': 'http://example.com' // http://example.com" & @CRLF & _
" "logger": {" & @CRLF & _
" "prefix": "dbug", // This is a comment" & @CRLF & _
" "level": "de\/\\//bug" /// Another comment" & @CRLF & _
" }," & @CRLF & _
" "url": "http://example.com" //// This should not be removed" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")