import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"(?:\\\\.|[^\"\\\\])*\"|'(?:\\\\.|[^'\\\\])*')|(\\/\\/.*$|^\\s*\\/\\/.*$)";
final String string = "{\n"
+ " \"example\": \"This is a // test\",\n"
+ " \"anotherExample\": \"This is another /// test\",\n"
+ " 'ap\\//ostr//ophe': 'http://example.com' // http://example.com\n"
+ " \"logger\": {\n"
+ " \"prefix\": \"dbug\", // This is a comment\n"
+ " \"level\": \"de\\/\\\\//bug\" /// Another comment\n"
+ " },\n"
+ " \"url\": \"http://example.com\" //// This should not be removed\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}