using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""(?:\\.|[^""\\])*""|'(?:\\.|[^'\\])*')|(\/\/.*$|^\s*\/\/.*$)";
string input = @"{
""example"": ""This is a // test"",
""anotherExample"": ""This is another /// test"",
'ap\//ostr//ophe': 'http://example.com' // http://example.com
""logger"": {
""prefix"": ""dbug"", // This is a comment
""level"": ""de\/\\//bug"" /// Another comment
},
""url"": ""http://example.com"" //// This should not be removed
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}