$re = '/(?:"(?:\\\\.|[^"\\\\])*"|\'(?:\\\\.|[^\'\\\\])*\')|(\/\/.*$|^\s*\/\/.*$)/m';
$str = '{
"example": "This is a // test",
"anotherExample": "This is another /// test",
\'ap\\//ostr//ophe\': \'http://example.com\' // http://example.com
"logger": {
"prefix": "dbug", // This is a comment
"level": "de\\/\\\\//bug" /// Another comment
},
"url": "http://example.com" //// This should not be removed
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);