// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:"(?:\\.|[^"\\])*"|'(?:\\.|[^'\\])*')|(\/\/.*$|^\s*\/\/.*$)"#).unwrap();
let string = "{
\"example\": \"This is a // test\",
\"anotherExample\": \"This is another /// test\",
'ap\\//ostr//ophe': 'http://example.com' // http://example.com
\"logger\": {
\"prefix\": \"dbug\", // This is a comment
\"level\": \"de\\/\\\\//bug\" /// Another comment
},
\"url\": \"http://example.com\" //// This should not be removed
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}