package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:"(?:\\.|[^"\\])*"|'(?:\\.|[^'\\])*')|(\/\/.*$|^\s*\/\/.*$)`)
var str = `{
"example": "This is a // test",
"anotherExample": "This is another /// test",
'ap\//ostr//ophe': 'http://example.com' // http://example.com
"logger": {
"prefix": "dbug", // This is a comment
"level": "de\/\\//bug" /// Another comment
},
"url": "http://example.com" //// This should not be removed
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}