use strict;
my $str = '{
"example": "This is a // test",
"anotherExample": "This is another /// test",
\'ap\\//ostr//ophe\': \'http://example.com\' // http://example.com
"logger": {
"prefix": "dbug", // This is a comment
"level": "de\\/\\\\//bug" /// Another comment
},
"url": "http://example.com" //// This should not be removed
}';
my $regex = qr/(?:"(?:\\.|[^"\\])*"|'(?:\\.|[^'\\])*')|(\/\/.*$|^\s*\/\/.*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}