#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^|\s)(?:\+?91)?[6-9]\d{9}\b"
Local $sString = "+916123456789" & @CRLF & _
"+916123456789" & @CRLF & _
"916123456789" & @CRLF & _
"6123456789" & @CRLF & _
"7123456789" & @CRLF & _
"5123456789" & @CRLF & _
"612345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")