re = /(?<=^|\s)(?:\+?91)?[6-9]\d{9}\b/m
str = '+916123456789
+916123456789
916123456789
6123456789
7123456789
5123456789
612345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end