$re = '/(?<=^|\s)(?:\+?91)?[6-9]\d{9}\b/m';
$str = '+916123456789
+916123456789
916123456789
6123456789
7123456789
5123456789
612345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);