const regex = /(?<=^|\s)(?:\+?91)?[6-9]\d{9}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\s)(?:\\+?91)?[6-9]\\d{9}\\b', 'gm')
const str = `+916123456789
+916123456789
916123456789
6123456789
7123456789
5123456789
612345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}