using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\s)(?:\+?91)?[6-9]\d{9}\b";
string input = @"+916123456789
+916123456789
916123456789
6123456789
7123456789
5123456789
612345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}