use strict;
my $str = '+916123456789
+916123456789
916123456789
6123456789
7123456789
5123456789
612345678';
my $regex = qr/(?<=^|\s)(?:\+?91)?[6-9]\d{9}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}