import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\s)(?:\\+?91)?[6-9]\\d{9}\\b";
final String string = "+916123456789\n"
+ "+916123456789\n"
+ "916123456789\n"
+ "6123456789\n"
+ "7123456789\n"
+ "5123456789\n"
+ "612345678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}