#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(\t{1,}|\s{1,}|)\-\-.*(\n|\r|\z)"
Local $sString = "-- Comment I want to ignore" & @CRLF & _
"SELECT * ," & @CRLF & _
" column_A + colB AS magic_sum FROM " & @CRLF & _
" (" & @CRLF & _
" SELECT * FROM A" & @CRLF & _
" UNION ALL" & @CRLF & _
" -- Ignore this pointless line" & @CRLF & _
" SELECT * FROM B" & @CRLF & _
" -- This line as well shoudl be removed" & @CRLF & _
" ) ORDER BY RAND()" & @CRLF & _
" -- limit to 10" & @CRLF & _
" LIMIT 10;" & @CRLF & _
"-- Ignore this"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")