$re = '/^(\t{1,}|\s{1,}|)\-\-.*(\n|\r|\z)/mi';
$str = '-- Comment I want to ignore
SELECT * ,
column_A + colB AS magic_sum FROM
(
SELECT * FROM A
UNION ALL
-- Ignore this pointless line
SELECT * FROM B
-- This line as well shoudl be removed
) ORDER BY RAND()
-- limit to 10
LIMIT 10;
-- Ignore this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);