const regex = /^(\t{1,}|\s{1,}|)\-\-.*(\n|\r|\z)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\t{1,}|\\s{1,}|)\\-\\-.*(\\n|\\r|\\z)', 'gmi')
const str = `-- Comment I want to ignore
SELECT * ,
column_A + colB AS magic_sum FROM
(
SELECT * FROM A
UNION ALL
-- Ignore this pointless line
SELECT * FROM B
-- This line as well shoudl be removed
) ORDER BY RAND()
-- limit to 10
LIMIT 10;
-- Ignore this`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}