use strict;
my $str = '-- Comment I want to ignore
SELECT * ,
column_A + colB AS magic_sum FROM
(
SELECT * FROM A
UNION ALL
-- Ignore this pointless line
SELECT * FROM B
-- This line as well shoudl be removed
) ORDER BY RAND()
-- limit to 10
LIMIT 10;
-- Ignore this';
my $regex = qr/^(\t{1,}|\s{1,}|)\-\-.*(\n|\r|\z)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}