package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(\t{1,}|\s{1,}|)\-\-.*(\n|\r|\z)`)
var str = `-- Comment I want to ignore
SELECT * ,
column_A + colB AS magic_sum FROM
(
SELECT * FROM A
UNION ALL
-- Ignore this pointless line
SELECT * FROM B
-- This line as well shoudl be removed
) ORDER BY RAND()
-- limit to 10
LIMIT 10;
-- Ignore this`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}