# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\t{1,}|\s{1,}|)\-\-.*(\n|\r|\z)"
test_str = ("-- Comment I want to ignore\n"
"SELECT * ,\n"
" column_A + colB AS magic_sum FROM \n"
" (\n"
" SELECT * FROM A\n"
" UNION ALL\n"
" -- Ignore this pointless line\n"
" SELECT * FROM B\n"
" -- This line as well shoudl be removed\n"
" ) ORDER BY RAND()\n"
" -- limit to 10\n"
" LIMIT 10;\n"
"-- Ignore this")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.