// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(\t{1,}|\s{1,}|)\-\-.*(\n|\r|\z)").unwrap();
let string = "-- Comment I want to ignore
SELECT * ,
column_A + colB AS magic_sum FROM
(
SELECT * FROM A
UNION ALL
-- Ignore this pointless line
SELECT * FROM B
-- This line as well shoudl be removed
) ORDER BY RAND()
-- limit to 10
LIMIT 10;
-- Ignore this";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}