#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<Type>\w+(?: +\p{Ll}\w*)*) +(?P<Brand>\p{Lu}\w*) *(?P<Collection>\p{Lu}.*?|) +(?P<Model>(?:\p{Lu}+ +)?[\d\p{Lu}][\d\p{Lu}/]*)$"
Local $sString = "Hair dryer Babyliss 6713DE" & @CRLF & _
"Hair dryer Philips Drycare Advanced HP8232/00" & @CRLF & _
"Photoepilator Philips Lumea Prestige BRI953/00" & @CRLF & _
"Hair straighteners Philips MoistureProtect HP8374/00" & @CRLF & _
"Hair styling combs Babyliss AS83PE" & @CRLF & _
"Epilator Braun Silk-épil 9 Flex SES 9030" & @CRLF & _
"Hair dryer Babyliss 5513PE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")