using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<Type>\w+(?: +\p{Ll}\w*)*) +(?P<Brand>\p{Lu}\w*) *(?P<Collection>\p{Lu}.*?|) +(?P<Model>(?:\p{Lu}+ +)?[\d\p{Lu}][\d\p{Lu}/]*)$";
string input = @"Hair dryer Babyliss 6713DE
Hair dryer Philips Drycare Advanced HP8232/00
Photoepilator Philips Lumea Prestige BRI953/00
Hair straighteners Philips MoistureProtect HP8374/00
Hair styling combs Babyliss AS83PE
Epilator Braun Silk-épil 9 Flex SES 9030
Hair dryer Babyliss 5513PE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}