// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<Type>\w+(?: +\p{Ll}\w*)*) +(?P<Brand>\p{Lu}\w*) *(?P<Collection>\p{Lu}.*?|) +(?P<Model>(?:\p{Lu}+ +)?[\d\p{Lu}][\d\p{Lu}/]*)$").unwrap();
let string = "Hair dryer Babyliss 6713DE
Hair dryer Philips Drycare Advanced HP8232/00
Photoepilator Philips Lumea Prestige BRI953/00
Hair straighteners Philips MoistureProtect HP8374/00
Hair styling combs Babyliss AS83PE
Epilator Braun Silk-épil 9 Flex SES 9030
Hair dryer Babyliss 5513PE";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}