import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<Type>\\w+(?: +\\p{Ll}\\w*)*) +(?P<Brand>\\p{Lu}\\w*) *(?P<Collection>\\p{Lu}.*?|) +(?P<Model>(?:\\p{Lu}+ +)?[\\d\\p{Lu}][\\d\\p{Lu}/]*)$";
final String string = "Hair dryer Babyliss 6713DE\n"
+ "Hair dryer Philips Drycare Advanced HP8232/00\n"
+ "Photoepilator Philips Lumea Prestige BRI953/00\n"
+ "Hair straighteners Philips MoistureProtect HP8374/00\n"
+ "Hair styling combs Babyliss AS83PE\n"
+ "Epilator Braun Silk-épil 9 Flex SES 9030\n"
+ "Hair dryer Babyliss 5513PE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}