const regex = new RegExp('^(?P<Type>\\w+(?: +\\p{Ll}\\w*)*) +(?P<Brand>\\p{Lu}\\w*) *(?P<Collection>\\p{Lu}.*?|) +(?P<Model>(?:\\p{Lu}+ +)?[\\d\\p{Lu}][\\d\\p{Lu}/]*)$', 'gm')
const str = `Hair dryer Babyliss 6713DE
Hair dryer Philips Drycare Advanced HP8232/00
Photoepilator Philips Lumea Prestige BRI953/00
Hair straighteners Philips MoistureProtect HP8374/00
Hair styling combs Babyliss AS83PE
Epilator Braun Silk-épil 9 Flex SES 9030
Hair dryer Babyliss 5513PE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}