use strict;
my $str = 'Hair dryer Babyliss 6713DE
Hair dryer Philips Drycare Advanced HP8232/00
Photoepilator Philips Lumea Prestige BRI953/00
Hair straighteners Philips MoistureProtect HP8374/00
Hair styling combs Babyliss AS83PE
Epilator Braun Silk-épil 9 Flex SES 9030
Hair dryer Babyliss 5513PE';
my $regex = qr~^(?P<Type>\w+(?: +\p{Ll}\w*)*) +(?P<Brand>\p{Lu}\w*) *(?P<Collection>\p{Lu}.*?|) +(?P<Model>(?:\p{Lu}+ +)?[\d\p{Lu}][\d\p{Lu}/]*)$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}