re = /^(?P<Type>\w+(?: +\p{Ll}\w*)*) +(?P<Brand>\p{Lu}\w*) *(?P<Collection>\p{Lu}.*?|) +(?P<Model>(?:\p{Lu}+ +)?[\d\p{Lu}][\d\p{Lu}\/]*)$/m
str = 'Hair dryer Babyliss 6713DE
Hair dryer Philips Drycare Advanced HP8232/00
Photoepilator Philips Lumea Prestige BRI953/00
Hair straighteners Philips MoistureProtect HP8374/00
Hair styling combs Babyliss AS83PE
Epilator Braun Silk-épil 9 Flex SES 9030
Hair dryer Babyliss 5513PE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end